Orchard 1.1

Apr 12, 2011 at 5:29 PM

I downloaded a new instance of Orchard 1.1 and installed the Open Auth v0.4.0 module. I enabled it as well as the Facebook login feature, however, I cannot seem to find where to configure my Facebook Client ID and Secret on the new version of Orchard. The configuration options used to be on the Settings screen, but they are no longer there. Any ideas on how to configure Open Auth on Orchard 1.1?

Apr 13, 2011 at 6:25 PM

Tried a new installation of Orchard and just noticed the error message when enabling the feature..."Post installation steps failed with error: Sequence contains no matching element".

Hope that helps with the issue.

Apr 13, 2011 at 9:59 PM

Hey psenechal, thanks for reporting. It looks like the admin area got screwed in the latest version. I have updated that and pushed to my mecurial instance. I am planning on releasing over the next day or two, I just want ot make sure everything is good for every one... or you could grab the latest code drop?

Apr 14, 2011 at 5:58 PM

Perfect...thanks for the update. I'll look for the new release when it's available.

Apr 18, 2011 at 8:09 PM

Hey, I have rolled out the updated version for 1.1, can you let me know how you get on??? Feedback always welcome :)

Apr 18, 2011 at 9:48 PM
Edited Apr 18, 2011 at 9:59 PM

How do we upgrade the module? When I upgrade I get error's now when I try and Enable them from the Modules page...

Regards,

Apr 18, 2011 at 9:54 PM

The module is on the gallery, Hmmm have a look here http://www.orchardproject.net/docs/Installing-and-upgrading-modules.ashx I think you flip to the upgrade tab and hit update... Can you see it?

Apr 18, 2011 at 10:14 PM
Edited Apr 18, 2011 at 10:15 PM

 

I tried that, and I still get an error when enabling them. I also see the Open Auth settings under Settings and added my info there... but when I goto login I dont see the facebook or other options, also when attempting to enable, i get an error and they stay disabled...

Apr 18, 2011 at 11:14 PM

Hey Nick,

I got the update working and I associated my Twitter account with my login. It allows me to login by clicking the Twitter image. I did notice, however, that when I go to the Admin area and look at Associated Accounts, I am not seeing anything listed. Shouldn't my association show up here? Also, if I click Add an account and try to add a Twitter association, it's saying that the association was already created. So I'm assuming the creation of the associations are working fine, they're just not showing up on the Associated Accounts tab.

Just thought I would let you know...Thanks for the awesome work!

Apr 18, 2011 at 11:31 PM

@xotj123 - We fixed issue by enablign the Orchard Feature as the enable button has now been moved to features.

@psenechal - Thanks dude!! thanks for the heads up. Will fix and roll out an small update in a couple days. :)